Ticket #193 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

jack2: starting two instances of same app in parallel does not work

Reported by: nedko Assigned to:
Priority: major Milestone: undecided
Version: 1.9.6 Keywords:
Cc:

Description

Steps to reproduce:

1. start jackd:

jackd -v -d alsa -d hw:0

(log attached)

2. start two jack_lsp apps in parallel:

(jack_lsp > 1.log 2>&1 &) ; (jack_lsp > 2.log 2>&1 &)

The first jack_lsp instance succeeds:

Jack: JackClient::SetupDriverSync driver sem in flush mode
Jack: JackPosixSemaphore::Connect jack_sem.1000_default_lsp
Jack: JackPosixSemaphore::Connect sem_getvalue 0
Jack: Clock source : system clock via clock_gettime
Jack: JackLibClient::Open name = lsp refnum = 2
system:capture_1
system:capture_2
system:playback_1
system:playback_2
Jack: jack_client_close
Jack: JackClient::Close ref = 2
Jack: JackClient::Deactivate
Jack: JackSocketClientChannel::Stop
Jack: JackPosixThread::Kill
Jack: JackClientSocket::Close
Jack: JackServerSocket::Close /dev/shm/jack_lsp_1000_0
Jack: JackPosixSemaphore::Disconnect jack_sem.1000_default_lsp
Jack: JackLibClient::~JackLibClient
Jack: JackShmReadWritePtr1::~JackShmReadWritePtr1 2
Jack: Succeeded in unlocking 120 byte memory area
Jack: JackLibGlobals Destroy 604050
Jack: ~JackLibGlobals
Jack: no message buffer overruns
Jack: JackPosixThread::Stop
Jack: ThreadHandler: exit
Jack: JackShmReadWritePtr::~JackShmReadWritePtr 1
Jack: Succeeded in unlocking 1040 byte memory area
Jack: JackShmReadWritePtr::~JackShmReadWritePtr 0
Jack: Succeeded in unlocking 82213408 byte memory area
Jack: jack_client_close res = 0

The second jack_lsp instance fails:

Cannot open lsp client
jack_client_open() failed, status = 0x21

Attachments

jackd.log (10.3 kB) - added by nedko on 09/08/10 17:36:42.

Change History

09/08/10 17:36:42 changed by nedko

  • attachment jackd.log added.

09/08/10 17:41:29 changed by nedko

The problem happens with other apps as well. I've tried yoshimi, jack-keyboard and qtractor.

09/16/10 04:54:16 changed by torbenh

checking client and allocating the clientname is not atomic. it happens in 2 different serverrequests. thats obviously not correct.

08/29/11 15:33:10 changed by nedko

  • status changed from new to closed.
  • resolution set to fixed.

This is fixed since r4503. Verified with r4534